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1.1 ¥1Au33n Microsoft Visual Studio

Microsoft Visual Studio A9 quﬁwmmmﬂsm (Integrated Development Environment)
Usgnauselusunsuvanes daildlunmsailusunsuduiasuuussuuufiRnisiulad vieldais
Julusunsy aaduudnis danisgrudeya wavdu Snannune

Visual Studio Mésausanedasiionmunsie Mdlunsiaulusunsudaus wiaeildwaun
1Usunsu (Development interface) m?laaﬁﬁﬂumimawmmﬂﬂﬂﬂmmm (Debugging tool) f%78
anludAlun1seulusunsu (Wizard tool) fiann15g1udaya (Database management) Way
duusznavduqfisndulumsiannlusunsy danuszneufudugn iSond Integrated

Development Environment (gaiaunlusunsy) vsesungas 31 IDE

1.2 AUEIU190UY Visual Studio
Huaiananuisvlulaseenst (Microsoft) 14lunisadhsdesne delud
v’ TUsunsu (Program)
v’ Auled (Website)
v Tusunsuuuiu (Web application)
v U3msuwdu (Web service)
v’ Aanduen (Cloud apps) 315 LALIHELNIAATIALBNNILTEUUARTIAYBIUT IV
Tulpswonsififidedn Azure
v Lenuugunsalnnm (Mobile apps)

v 1nud (Games)



1.3 1aesilaluyn Visual Studio
Visual Studio Msramanaq wdesdeildlunsdeulusunsuniueneg wazausadeuluswnsy

mnmuwilafldmuiisain lnefiniedlonmelul

v Visual Basic

v’ Visual C++

v’ Visual C#

v’ Visual F#

4 Python

v JavaScript

1.4 NsAnas Visual Studio

(%
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Tun1sfnds Visual Studio Yagiuihiu Version 2019 dsanunsaniulvaalang wazfnAmiu
TupaUise Ul

1.4.1 Lém’f‘uvﬁ%jﬁui“dﬁ https://visualstudio.microsoft.com iy Visual Studio IDE \den

Download Visual Studio -> Community 2019 aunl 1.1

Visual Studio

Best-in-class tools for any developer

Visual Studio IDE Visual Studio Code Azure DevOps
§ jet Agile t it, continuc

anced debugging Editing and debugging on any OS ]

Download for Windows > Get started fc
>

Enterprise 2019

AN 1.1


https://visualstudio.microsoft.com/

a o =

1.4.2 azUsnguaviansanusliidoninawmesiiazduiiniusunsuianilvasiulilueses

1.4.3 Ualnawmeasniinistuiinlusunsuld wdviinis Run Lievinnisinsis azUsinguiinma

wansEn1UzN1IANUMan Visual Studio TunoutagliIATUIUNDALAIT AUATNA 1.2

Visual Studio Installer

"* Almost done ... Getting everything ready.
Downloaded

Installed
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1.4.4 Funeurell Wenilvanasa aziivtieng installing Juun Iivinnsidendivhde NET

desktop development LL&’hﬂﬂﬁm Install A nd 1.3

Installing — Visual Studio Community 2019 — 16.1.2

Workloads Individual components Language packs

E; Build web applications using ASP.NET, ASP.NET Core, IL

HTML/JavaScript, and Containers including Docker support.

Installation locations
Azure SDKs, tools, and projects for developing cloud apps,
creating resources, and building Containers including...

Node.js development
Build scalable network applications using Node.js, an

P Python development
Editing, debugging, interactive development and source
control for Python.

®

asynchronous event-driven JavaScript runtime.

Windows (3)

mr

.NET desktop development
Build WPF, Windows Forms, and console applications using
C#, Visual Basic, and F#.

Desktop development with C++
Build Windows desktop applications using the Microsoft
C++ toolset, ATL, or MFC.

-- Universal Windows Platform development
Hl Cceate applications for the Universal Windows Platform
with C#, VB, or optionally C++.

Gaming (2)

A Game development with Unity ¥+ Game development with C++
Location
C:\Program Files (x86)\Microsoft Visual Studio\2019\Community Change...

By continuing, you agree to the license for the Visual Studio edition you selected. We also offer the ability to download other software with Visual Studio. This software
is licensed separately, as set out in the 3rd Party Notices or in its accompanying license. By continuing, you also agree to those licenses.
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Installation details

> Visual Studio core editor
v .NET desktop development
Included
¥ _NET desktop development tools
¥ _NET Framework 4.7.2 development tools

v C# and Visual Basic

Optional
NET Framework 4 — 4.6 development tools
Blend for Visual Studio
Entity Framework 6 tools
NET profiling tools
Just-In-Time debugger
Live Share
IntelliCode
F# desktop language support
[ PreEmptive Protection - Dotfuscator
NET Core 2.2 development tools
.NET Core 2.1 development tools
NET Framework 4.6.1 development tools

NET Framework 4.6.2 development tools

Total space required

2.71 GB

Installwhiledownloading"m Install ‘
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Visual Studio Installer

stalled Available

04 Visual Studio Community 2019

Downloading and verifying: 10 MB of 795 MB
1% u

Installing: package 2 of 273
0% 1
Microsoft.VisualStudio.MinShell.Resources

Start after installation

Release notes

(752 KB/sec)
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Pause

1.4.6 defnmalUsunsutasaseusesndinnisaldeu Visual Studio asauwsn 1vvinnag

aangzileu 3o Sign in Weawmeileugldlnl (aumiloutunmsadnsduad outlook) vinsiden

ANTNLINFOUNDIR

Visual Studio

Welcome!
Connect to all your developer services.

Sign in to start using your Azure credits, publish code to a private Git
repository, sync your settings, and unlock the IDE.

Learn more

No account? Create one!

Not now, maybe later.
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1.5 B3uaulgeu Visual Basic

15192153199U Visual Basic @sazldAgnin VB lastsnageduistitdiuusznoud1es waznaia
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wann1sleulusunsuiie VB idnduseamsu tneussandlddssinag dail
1.5.1 af1alusidnduaziinadiunisvinaulu Visual Studio

1) Wsiand (Project) fie Tasanisdauenndintuniusznaumelnanisviinusivegluys

[

Weaiu Sususazasalusidndluml antduariansadiun1sineuaie eenununnngliladnu fadl

Visual Studio 2019

Open recent Get started

13 WindowsAppl.sin 3

% Clone or check out code
et code from an online repository ke

m ConsoleApp1.sin

(@ Open a project or solution
Open a local Visual Studio project or sin file

f: .Opeh a local folder »

+ ;
@ Create a new project

A 1.7
2) Henmumanfuwuy Windows Forms App (Net Framework) kaanata Next 91y

m‘wﬁ 1.8

WPF App (.NET Framework)

Windo tation Foundation client application

Visual Ba Windows Desktop

B Class Library (NET Standard)

A project for creating a ¢

mac0S Windows Library

Visual Basic Windows Desktop

B Class Library (NET Framework)

A project for creating a \

Visual Basic Windows Library
Unit Test Project (NET Framework)
A project that contains unit tests.

Visual Basic Windows Test

"“ Windows Forms Control Library (NET Framework)
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3) vin1sAstialusiingd \deon Location Mdesn1studin udnalu Create n1wil 1.9

Configure your new project

Windows Forms App (.NET Framework)  VisualBasic  Windows  Desktop
Project name

Week1

Location

C\Users\PuMp\source\repos

Solution name ®

WindowsApp1
D Place solution and project in the same directory
Framework

NET Framework 4.7.2

A WA 1.9
4) UsnwesuinednueenuuuntnaslusunsuwashanddIun1sinausgeg Ami 1.10

IS a £ -dy
UINYALLRIYNANU

uq File Edit View Project Build Debug Format Test Analyze Tools Exensions Window

B-oud Debug - AnyCPU - p Stat- M

% Formlvb [Design] + X

& Solution "Week1' (1 of 1 project)
4 [®] Week1

b [ Formlxb

Team Explorer
Nindows.Forms.Form

Sizable
No
False
Form1
UseWaitCursor False
= Behavior
AllowDroo False
Text
The text associated with the control.

4 Addto Source Control =
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> Wyu1s (Menu bar) Huuausimimdsimuelu V8

> yaun$ (Toolbar) Auamzusdids uiidumdsitlives

> yadend (Toolbox) iuneulnsauazaeslmuudmingg Misranmsadenlunsasuumesy
1 ieeenuuuniiaelusunsy (Benidwfnseld ve User Interface

> wihsauanslusiand (Solution Explorer) iunthssuanisieaziBonvesliduaslugad
filulusidne

> wihsnanauas (Properties Window) 1unthsiuansqaiasifivasnsulnsauas
rovlunsifidoneglunneiu SasannsaUiuuinuausRifanduld wu dvue
fomnu USUE USurun Juegiuseuiindfiden

> wosu (Form) fiuiifldluniseonuuuniihrelusun tnelvisianaouinsauas
ARLLILUUANNANINUTENOURUAINABINTS

> unasloya (Data Sources) @31un1silienseuazfnsegiudoya

5) 111019 Code Editor wagnusing Designer
N v . d 1o o A o
aEnsasenvingng Code Editor Nlvildrdaitoniununisvinuredusunsy log
N3Id0NAIEY View -> Code #30na F7 wsinnsn1saduluvinauuuniisig Designer Tdanands

View -> Designer 3ona Shift+F7 a1unndl 1.11

Project Build Debug Format Test Analyze Tools

Edit View Project Build Debug Test Analyze Tools Extensions

F7 - B Start - P
Shift+F7

B-mElH ?- Debug -~ AnyCPU - p Start -~

%  Toolbox v 0 X Formlwb® ® X Forml.vb [Design]*

p- el

4 General

There are no usable controls in
this group. Drag an item onto
this text to add it to the toolbox.
b Componen ° = Ctrl+Alt+K
p Printing Ctrl+Shift+C
b Dialogs
b WPF Interog

de Definition Window Ctrl+w, D
0 Ctrle A

4 General 27 Ctrl+ Alt+)

Error List Ctrl+w, E

Ctrl+Alt+0

Ctrlsw, T

Ctrl+Alt+ X

Ap@Rc A6

Ctrl+w, Ctrl+N
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6) NNSIANITABUINTALAZNITATNUADLIUR

6.1) N159AN15ABUINTA N1SNABUINTAaaIUUNDSY 19189l AND 1.12 kaLLs)
anunsaimueRaudRsiie lanntneauaud (Properties Window)

Do File Edit View Project Build Debug Test Analyze Tools Extensions Window Help

Q- B e Debug ~ AnyCPU - b Stari- A _

5 Toolbox sessses w I Form1vb* Form1.vb [Design]*
P~ © scaling on your main display is set to 125%. Restart Visual Studio with 100% scaling  Hel
b All Windo
" 4 Common
Pointer
Button

Che:

Combo!
DateTimePicker
Label

LinkLabel

k

o
B
i)
A
A
Eg

TreeView
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6.2) NSAINUADLIUR

1A i3

Code Editor {uniiesiiisnlamdsas VB adlu ienauaussediiudeiieg 7
Aoty annsadn/avtieneild Tnenatu F7 videideniuy View->Code ndlil i1avandldisnd
MessageBox.Show lulusunsu uainsmageulusiunsu

Forml

Showl.Click
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TUsunsuisimunme VB asUsenaumediugosq 158031 Tuga (Module) @4luga

[ ]
IS I

wiandl Wethunsiuiu 1513e5eni1 WsRnd (Project) nstuiinluswnsuisnasne Ade nstudin

1 aa 4

TUs1An¢ Faaziley 3 35 A

Y

o
Y

> mstufinlnslulusidnsviomn 1snden File -> Save Al Faszuuazaialiawes
govdmsudniulusdnduazaselndlusdndanudeveslusing wamnisldmas
Hlurdasiold Aozdunstuiinsmanlndimaadavhaululusdndiaue
> nsduiinlusidndludediu Tsden File -> Save [@ovedlusidnd] diflndlngi
Lﬁqa%’mwié'ﬂaigﬂﬁ’uﬁﬂ VB 2lissdtelndduitevhnistuiingae
> nstuiinlusidndludeln Tisaden File -> Save [ ] as azfunisadralusidndde
Tvsi ToeTusidnddeiinfidansogmiloufia
8) N1INAEaUlUTLATH
iansnsasulusunsniiensanasunsinau Tasnatu F5 videidendds Debug ->
Start Debugsging
yndesmsginsmaaeulusunsy Iipdniituninuivaveslusunsy wienaty
<Ctrl+Alt+Bre-ak> w3afas Debug -> Stop Debugging
9) Buduasalusunsuusn
dsululusunsutl asadrlusunsuiisudonnuandld iefinisadinunddu Say

[

Hello Aazuanadeninuiilisusguunasdaninu fail

WindowsApp2 X

Name  [Traiard Hello, Thailand
QK
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- @enpaulnsasing a1nyadend (ToolBox) 1na1suumesy

k  Pointer
Button

®
|

L 1

Sav Hello

Notifylcon
NumericUpDown

irERe i BER E
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- AvunanuantRvesnoulnsasiag iviiheing Properties

- donuy View->Code Liteilantisiadeuldndds (Code Editor)

- a¥anmanauaussiisieants Tusegnsie naty Button1 Tilyitaanu fedu wihshs
{Jeu Code Ada Tis1den Buttonl wagtdendiaus Click fagu

amlvb* # X Formlvb [Design]*
v @ Button1 Click

Click

Forml
. ClientSizeChanged
Buttonl_Click(sender
ContextMenuStripCt
ControlAdded
ControlRemoved

CursorChanged

DockChanged
DoubleClick
DpiChangedAfterPa

DpiChangedBeforef

MmOl N Ol R R R R h R W

DragDrop
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- fnsiiis Code Adanssy

Forml

Buttonl.Click
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- ANAY MsgBox AzlanInaadtanInu (Message Box) MH70ANLANFDU TaBts1an
vuaAild 2 A1 AUAIBLATEMIN () Fedenuiikanduazduns

AsN “Hello, “ & TextBoxl.Text hansA1I1 Hello (fdnusiegluinIaaing

“ ) aztududaniu luldend) Pnusemetenufioglu TextBox1 Feazidudomnuisfiu
adlumaulnga 1neyinnNISIYaNTaANUVERINIULATDINLNY &

AEa MsgBoxStyle.OkOnly Lun1sivuaduivzuandlunasidaniny

- INUUINNTSULUTWATY haznadauluswhnsy



